Problem

Bei Nutzung des Hosted Tokenizaion IFrames (Flex Checkout) treten diese Fehler auf:

  • Alias [object Object] not Found
  • Your payment data could not be saved
  • Die Zahlungsdaten konnten nicht gespeichert werden
  • FAILURE_TOKEN


Im ops.log erscheint möglicherweise:

  • did not save alias due to empty alias

Ursache

Die erforderlichen Parameter (z.B. "Alias.AliasId") werden nicht von Ingenico an den Shop gesendet, höchstwahrscheinlich, weil sie im Ingenico-Backoffice nicht aktiviert sind.


Lösung 1

Öffnen Sie im Ingenico-Backoffice den Bereich "Konfiguration -> Technische Informationen -> Transaktions-Feedback" in den separaten Abschnitt "Alias gateway and Tokenization". Aktivieren Sie alle dynamischen Parameter in diesem Abschnitt.


Aktivieren Sie alle dynamischen Parameter für "Alias

Gateway and Tokenizationim markierten Abschnitt


Lösung 2

Prüfen Sie im Magento Admin Panel, ob der Umgebungs-Umschalter (zur Auswahl von Test / Produktiv) auf "Angepasst" steht. Falls ja, prüfen Sie, ob die Alias Gateway URL stimmt.