Problem

  • Wenn ein Käufer im Checkout "Zahlungsdaten speichern" gewählt hat, wird der Alias in Magento angezeigt, bleibt aber auf "ausstehend" (pending). Er geht nicht auf "aktiv".
  • Im Ingenico Backoffice ist kein Alias gespeichert.


Ursache

Das Alias Feld in der Datenbank erlaubt nur 32 Zeichen. Der Wert von Ingenico kann jedoch länger sein. Das führt zu einem Fehler, wenn beim Order Request der Alias geladen werden soll. Dadurch wird dann der Parameter ALIASPERSISTEDAFTERUSE = N an Ingenico geschickt, wodurch der Alias bei Ingenico gelöscht wird.


Lösung

Bitte ändern Sie in der Alias Spalte in der Tabelle ops_alias den Typ von varchar(32) auf varchar(255). Die entsprechende SQL-Abfrage ist

ALTER TABLE ops_alias MODIFY alias VARCHAR(255);


Dieses Problem betrifft Modulversionen bis einschl. 16.12.14. In neueren Versionen ist das Problem behoben.