Problem

Der Bestellstatus Magento wechselt auf "Betrugsverdacht" (Suspected fraud).


Mögliche Ursachen

  1. Der in Magento gespeicherte Betrag entspricht nicht exakt dem Betrag, der von Ingenico zurückgesendet wurde.
  2. Die Erfassung (Capture) der Bestellung wurde ausgelöst, aber der vollständige Betrag wurde bereits zuvor erfasst.
  3. Das Ingenico-Modul setzt diesen Status, wenn von Ingenico im Feedback der Status "50" (Authorized waiting external result) gesendet wurde.
  4. Das Transaktions-Feedback wird mehrfach von Ingenico an den Shop gesendet. Es sollte nur ein einziges Mal gesendet werden.

Lösungen

  1. Prüfen Sie im Ingenico Backoffice, ob dort Nachlässe (Discount) oder Zusatzkosten (Surcharge) eingestellt sind, und stellen Sie sicher, dass der Parameter AMOUNT aktiviert ist (Abschnitt "Dynamic Feedback Parameters").
  2. Prüfen Sie die Bestell-Kommentare, ob eine Erfassung ausgelöst wurde, obwohl der gesamte Betrag bereits erfasst war. Stoßen Sie alle Transaktionen (Erfassung, Erstattung, etc.) immer in Magento an, nicht im Ingenico Backoffice.
  3. Prüfen Sie die Betrugserkennung (Fraud Detection) bei Ingenico, ob dort Status "50" gesetzt wurde.
  4. Wenn das Transaktions-Feedback mehrfach eingeht (siehe Screenshot), erhält die Ingenico-Plattform vermutlich nicht den korrekten HTTP Antwortcode vom Shop.
    • Möglicherweise wurde der Shops so angepasst, dass nicht mehr der richtige HTTP Antwortcode an Ingenico gesendet wird.
    • Wenn eine Exception auftritt, während das Transaktions-Feedback eingeht, kann das ebenfalls dazu führen, dass kein HTTP Antwortcode an Ingenico gesendet wird, und die Ingenico-Plattform dann das Feedback nochmal sendet.
    • Prüfen Sie in den Logs von Magento und PHP, ob es Exceptions gibt, wenn das Feedback eingeht, und beheben Sie diese.


Mehrfach eingehendes Transaktions-Feedback

(achten Sie auf die Zeitstempel)