Problem
Bei Nutzung einer Ingenico-Zahlart werden die Bestellbestätigungs-Emails von Magento nicht verschickt.
In der Bestellung im Admin-Panel steht "Bestätigungs Email nicht verschickt" (oder ähnlich).
Bei Nutzung anderer Zahlarten (z.B. Check / Money Order) funktionieren die Emails korrekt.
Mögliche Ursachen
- Das Transaktions-Feedback von Ingenico erreicht den Shop überhaupt nicht, oder
- beim Eintreffen des Feedbacks tritt eine Exception in Magento auf. Dadurch bricht der Prozess ab, bevor die Mail verschickt werden konnte.
Lösungen
- Prüfen Sie, ob das Transaktions-Feedback den Shop erreicht. Dazu kann diese Checkliste verwendet werden.
- Aktivieren Sie die Parameter im Ingenico Backoffice auf dem Tab "Transaktions-Feedback" in den Abschnitten:
- Dynamische e-Commerce Parameter
- Alias gateway und Tokenization -> Dynamische Parameter
- Beachten Sie auch die Infos in diesem FAQ-Artikel.