Problem

Bei Nutzung einer Ingenico-Zahlart werden die Bestellbestätigungs-Emails von Magento nicht verschickt.


In der Bestellung im Admin-Panel steht "Bestätigungs Email nicht verschickt" (oder ähnlich).


Bei Nutzung anderer Zahlarten (z.B. Check / Money Order) funktionieren die Emails korrekt.


Mögliche Ursachen

  1. Die Emails sind in der Magento-Konfiguration abgeschaltet.
  2. Das Transaktions-Feedback von Ingenico erreicht den Shop nicht.
  3. Beim Eintreffen des Feedbacks tritt ein Fehler auf. Dadurch bricht der Prozess ab.

Lösungen

  1. Prüfen Sie die Option "Rechnung an Kunden schicken" in der Konfiguration "Zahlungsdienste".
  2. Prüfen Sie, ob das Transaktions-Feedback den Shop erreicht. Dazu kann diese Checkliste verwendet werden.
  3. Aktivieren Sie die Parameter im Ingenico Backoffice auf dem Tab "Transaktions-Feedback" in den Abschnitten:
    • Dynamische e-Commerce Parameter
    • Alias gateway und Tokenization -> Dynamische Parameter
    • Achtung: aktivieren Sie nicht die Parameter "ECOM..." und "CN".
  4. Beachten Sie die Informationen in diesem FAQ-Artikel.