Problem

  • Wenn im Checkout das Hosted Tokenization IFrame (Flex Checkout) angezeigt werden soll, passiert nichts.
  • Der Benutzer sieht keine Fehlermeldung.
  • In der Browserkonsole werden ein Error 500 und das Stichwort "generateHash" angezeigt.


Ursache

Es wird eine inkompatible PHP-Version verwendet. Das Hosted Tokenization (Flex Checkout) Feature benötigt mindestens PHP 5.4, um zu funktionieren.


Lösung

Stellen Sie sicher, dass eine offiziell unterstützte PHP-Version verwendet wird (mind. 5.4). Ältere Versionen wie z.B. PHP 5.3 funktionieren nicht.