Problem

Im Checkout werden keine Ingenico-Zahlarten angezeigt.


Die folgende Fehlermeldung erscheint im Zahlungsschritt. Die Meldung verschwindet ggf. nach einigen Sekunden.


Could not fetch payment options from Ingenico Connect API. Please select another payment method.

Ursache

Dies ist eine allgemeine Fehlermeldung, die verschiedene Ursachen haben kann.


Zuerst müssen die Dev-Tools geöffnet werden wenn der Checkout durchlaufen wird. Wählen Sie den Tab "Network" und aktivieren Sie "Preserve log".


Gehen Sie dann durch den Checkout-Prozess, bis der Fehler auftritt, und prüfen Sie, welche der u.g. Lösungen zutrifft.


Lösung #1

Wenn die Response des URL-Aufrufs "products" an die Ingenico-Plattform ein leeres JSON-Array zurckgibt:

{
    "paymentProducts" : [ ]
}

dann hat die Ingenico-Plattform keine Zahlarten für die gegebene Kombination aus Währung, Betrag und Rechnungsland zurückgegeben.


Prüfen Sie, ob bei Ingenico Zahlarten aktiviert sind, welche die aktuelle Kombination aus Währung, Betrag und Rechnungsland erlauben. Die GET-Parameter im "products"-Aufruf zeigen, welche Informationen gesendet wurden.


Lösung #2

Wenn die Response des URL-Aufrufs "?sections=connect_session..." an die Shop-URL diesen Fehler beinhaltet:

{"connect_session":{"error":"cURL error 6 (Couldn't resolve host name) ... }}

dann stimmen die API Endpoint URLs in Magento nicht. Eine ähnliche Meldung ("Couldn't resolve host name") sollte auch im Ingenico-Log zu finden sein.


Prüfen Sie unter "Konfiguration -> Verkäufe -> Ingenico ePayments -> Account Settings" ob die API Endpoints korrekt eingegeben sind.


Bei Speichern der Konfiguration wird ein automatischer Test durchgeführt. Das positive Testergebnis wäre:


Connection to the Ingenico Connect platform could successfully be established.


Lösung #3

Wenn die Response des URL-Aufrufs "?sections=connect_session..."an die Shop-URL diesen Fehler beinhaltet:

{"connect_session":{"error":"The server returned an error." ... }}

prüfen Sie die Ingenico Log-Datei in Magentos Log-Verzeichnis auf genauere Informationen, z.B.:


MISSING_OR_INVALID_AUTHORIZATION -> Der API Key ID oder API Secret sind nicht korrekt.


ACCESS_TO_MERCHANT_NOT_ALLOWED -> Die Merchant ID (MID) ist nicht korrekt eingestellt.


Lösung #4

Wenn überhaupt keine Verbindung zur Ingenico-Plattform aufgebaut werde kann, prüfen Sie, ob die IP-Adresse des Shops in die Whitelist eingetragen ist. Im Zweifelsfall nehmen Sie bitte Kontakt mit dem Ingenico Support-Team auf.