Log entries like the following mean that no corresponding transaction could be found in Magento for the Directlink request.

2014-04-10T09:10:29+00:00 DEBUG (7): Run into exception 'Warning, transaction count is 0 instead of 1 for the Payid "...", order "294" and Operation "capture".' in directLinkPostBackAction

 

Cause:

This can occur when the merchant changed the status of a transaction in  the Ingenico backend, or if a refund has been issued there instead of from the Magento Admin Panel.


Solution:

The correct procedure is to trigger all transaction changes or refunds from the Magento Admin Panel only.


To make a refund, make sure to follow the correct workflow, see this article.