Problem

Folgende Fehler treten auf:

  • SHA mismatch
  • NCERROR" ... 50001111
  • unknown order/1/s

Ursache

Alle o.g. Fehlermeldungen haben die gleiche Bedeutung: der Vergleich der Hashes (SHA strings) von Ingenico und Magento ist fehlgeschlagen. Das kann mehrere Ursachen haben.


Lösung 1

Prüfen Sie die Konfiguration:

  • Passwort für den API-Benutzer max. 16 Zeichen lang.
  • PSPID mit korrekter Groß-/Kleinschreibung.
  • Algorithmus (SHA-1, SHA-256, etc.) identisch in Magento und dem Ingenico-Backoffice.
  • SHA IN / OUT sind identisch und nicht länger als 20 Zeichen.
  • Keine Sonderzeichen oder Umlaute, nur Buchstaben und Ziffern enthalten.
  • Alle Werte müssen in Magento und dem Ingenico-Backoffice identisch sein.


Lösung 2

Deaktivieren Sie die Parameter "ECOM_BILLTO..." und "ECOM_SHIPTO..." im Ingenico-Backoffice.


Lösung 3

Deaktivieren Sie die Option "Zusätzliche Parameter übertragen" in Magento unter "Zahlungsdienste".


Lösung 4

Prüfen Sie, ob in Name oder Adresse Umlaute (ä,ö,ü) oder Sonderzeichen (z.B. ß, é, è) enthalten sind. Testen Sie, ob ohne diese Zeichen der Fehler dennoch auftritt.