Symptom:

In der Kreditkarten-Konfiguration ist eingebettete Zahlung (Inline) aktiviert. Trotzdem wird der Käufer im Checkout auf die externe Bezahlseite weitergeleitet (Redirect).


Ursache:

Dieses Problem tritt auf, wenn die JavaScript-Datei payment.js nicht im Checkout eingebunden ist. Diese Datei übernimmt das Handling des gewählten Kreditkartentyps (VISA, Mastercard, etc.), zeigt die entsprechenden Eingabefelder an und überträgt die Eingaben.


Lösung:

Die JS-Datei muss in den Checkout eingebunden werden. Sie ist zu finden unter /js/netresearch/ops/payment.js