Problem:

  • Kreditkartenzahlungen sind auf Redirect eingestellt (d.h. Umleitung zur externen Bezahlseite, auf der die Kreditkartendaten eingegeben werden sollen).
  • Es erscheint die Meldung "Zahlung fehlgeschlagen" / "Zahlung nicht erfolgt" im Checkout.
  • Im Log /var/log/ops.log erscheint bei den betreffenden Einträgen "Direct Link Request/Response in Ingenico".


Mögliche Ursache:

Möglicherweise wird eine Fremd-Extension verwendet (z.B. "Offline Maintenance"), um den Shop in einen Wartungsmodus zu versetzen. Wenn man gleichzeitig im Magento-Backend eingeloggt ist und gleichzeitig im Frontend eine Zahlung durchführen will, kommen dadurch die Sessions durcheinander. Der Checkout verhält sich so, als würde die Bestellung im Backend durchgeführt. Deswegen wird ein Direct Link-Request durchgeführt, obwohl die Zahlart auf Redirect eingestellt ist (weil im Backend nur Direct Link Inline-Zahlungen verwendet werden können).


Lösung:

Sobald der Wartungsmodus deaktiviert ist, tritt das Problem nicht mehr auf. Entweder muss auf die Nutzung der Fremd-Extension für den Wartungsmodus verzichtet werden, oder dieser besondere Umstand muss bei Tests generell beachtet werden.