Problem:

  • Nach Abschluss des Kaufprozesses erscheint "Zahlung fehlgeschlagen", aber der Käufer wird trotzdem belastet.
  • In Magento wird keine Bestellung angelegt.
  • Im ops.log findet sich evtl. die Fehlermeldung "The data you entered is not correct".


Mögliche Ursache:

Dieses Verhalten kann auftreten, wenn beim Speichern der Bestellung eine Exception auftritt. Zu diesem Zeitpunkt sind die Zahlungsdaten aber bereits an den Zahlungsanbieter übertragen, deswegen wird der Käufer belastet.


Das Modul schickt dann erneut einen Request an den Zahlungsanbieter, welcher aber zum Fehler "The data you entered is not correct" führt, weil die Order ID bereits zuvor verwendet wurde. Diese Meldung ist also eine Folge der Exception und nicht selbst die Ursache für das Problem.


Behebung:

Es müssen alle verfügbaren Log-Dateien geprüft werden, wo genau die Exception auftritt, und wodurch sie verursacht wird.


Oft sind fremde Magento-Module die Ursache, z.B. wenn diese in deren "sales_order_place_after"-Observer aktiv werden wollen.